Hearing myself Sing

WarmBadgerWarmBadger Unsigned
edited December 2009 in The Beatles: Rock Band
In rockband 2 I could reduce the mic volume so that I wouldn't actually hear myself singing over the television. With the Beatles and can't find a way to do that even when I have it on the lowest setting. I find it really hard to play this way and it's getting frustrating.

Right now I've got the vocal track at highest setting and microphone is at lowest. still no luck. Is there a setting I'm missing to get my voice off the television so I can enjoy hearing the Beatles sing rather than listening to myself?

Comments

  • dlowelldlowell MAJOR Noob
    edited September 2009
    I think there are user specific options, and one of them is for mic volume. i think its menu menu > options > user options (or something like that)
  • MysticDwagonMysticDwagon Unsigned
    edited September 2009
    it sounds like one of several things wrong with you and your settings, first and foremost, the mic sensitivity NEEDS to be low, if its at 50% or higher, youre still going to be singing with lots of distortion from your speakers unless you are singing about 8 or more inches from the mic.
    second, you might just be singing either too loudly and/or too close to the mic, even if the mic volume is set too 0% if you put your mouth right up to the mic and talk normally, you will still be heard through the speakers with massive distortion.

    best advice, just back off the mic about 2-4 inches and sing compfortably, set the mic sensitivity to about 25 or 30% and the mic volume to 0%

    a good way to tell if you are singing just too loud or too close to the mic, is watch the arrow, if it turns SOLID while you are singing, youre too close or too loud, it should stay a little bit 'see-through'. the louder you are, the more non-transparent the arrow is, the quieter you are, the more it fades out
  • Dave_ThDave_Th Opening Act
    edited September 2009
    I was hopeful when I read these replays but I have now been through every option and setting and there is no way to turn off my voice. This does not happen on all songs, I first noticed it on Come Together then again on Back in the USSR. I doesn't happen on Twist and Shout, so I am not sure what the cause and effect are.

    This is darn annoying. I really don't like to hear my self sing, and I cant hear the great music over my own caterwauling.
  • OinkThePigOinkThePig Unsigned
    edited September 2009
    To adjust the mic volume, the easiest way I've found is to start a song as a vocalist, then pause the game and go to the audio options from there. You should be able to adjust the mic sensitivity and the volume of your vocals.
  • oRabbitoRabbit Opening Act
    edited September 2009
    I hate my voice too...it's annoying to hear it amplified. Know how to turn mic volume down, but as OP stated, can't find a way to turn off as much as in RB2
  • sampansampan Unsigned
    edited September 2009
    hold down the A button(360 controller) during a song and it lets u adjust the mic volume.i have mine set as low as it goes and cant hear myself at all.
  • RotBotRotBot Unsigned
    edited September 2009
    People who can and can't turn off mic volume, are you on PS3 or 360? I'm on PS3 and turning the mic volume up and down does nothing for me.

    Edit: The slider actually does change the volume up and down, but at the lowest setting, you can still hear the mic. In regular Rock Band, the lowest setting has a much lower volume so that it's muted at almost all times, except when you cup your hand over the mic and scream into it.
  • niphtyniphty Unsigned
    edited September 2009
    I've noticed that the mic volume, at least for me on the PS3 as well, doesn't really go 'low', it just goes from loud to normal, lol. I don't HATE my voice, but I can't hit key well yet, so I'd much rather listen to them. Plus it's helpful to actually hear their harmonies to better help find where it is I need to be singing =D Hearing myself only makes me miss it more, haha.
  • C-Pr0mptC-Pr0mpt Rising Star
    edited September 2009
    I'm also suffering from this problem as a PS3 user.
  • GryffindorGryffindor Road Warrior
    edited September 2009
    Same problem here. I have the mic volume setting all the way to the left and I can still strongly hear my vocals coming through.

    If you lower the sensitivity it does help some BUT if you do this the game has a harder time picking up your vocals. In RB2 I always keep my sensitivity setting at 2 notches from the left. In TB:RB it must be kept at about 2 notches from the right.
  • C-Pr0mptC-Pr0mpt Rising Star
    edited September 2009
    I've given up on trying to find a fix to this issue. I have gone back to RB2. =\

    I'll just have to wait for the DLC to come out and bring out the guitar again. It's too frustrating trying to do vocals while not being able to fix this issue.
  • ArmeniusLODArmeniusLOD Opening Act
    edited September 2009
    Does hearing your own voice while singing really take the joy out of the game for you? When I'm singing I can't hear my own voice coming through the speakers on the highest mic volume setting.
  • GryffindorGryffindor Road Warrior
    edited September 2009
    ArmeniusLOD;3055639 said:
    Does hearing your own voice while singing really take the joy out of the game for you? When I'm singing I can't hear my own voice coming through the speakers on the highest mic volume setting.
    Yes it does. If you are trying to match harmonies and all you can hear is yourself it makes it damn hard. To make matters worse is the horrible mic latency so not only are you hearing yourself but you're hearing yourself from about 3 seconds ago.

    Is this only affecting PS3 owners? If so, was this the remedy to SAS?
  • lotr rocks 0lotr rocks 0 Road Warrior
    edited September 2009
    i can hear myself sometimes but not too badly... I think i'm just naturally quiet.... people often have trouble hearing me even when I feel like i'm talking normally or even loudly sometimes.... I just turn down sound all the way and its fine mostly

    EDIT: I'm on 360
  • Thekirby45Thekirby45 Opening Act
    edited September 2009
    Its on the wii as well
  • dragonflyrdragonflyr Rising Star
    edited October 2009
    had a beatles party the other night ... and a lot of people complained about this. (i'm on a ps3).

    even with sensitivity and volume turned way down, the mic was still loud. if you really tried hard to sing "softly", you were ok. but, with a loud stereo (music playing pretty loud), the person singing was often louder than the music. it was VERY annoying.

    so, yeah .. i completely understand this. On RB2 it is not a problem at all. If you wanna be heard, you can..if not, you turn down mic volume and it's all good. So, yes, this is an issue. it had a negative impact on the evening.
  • RockBandoleerRockBandoleer Opening Act
    edited October 2009
    May be a sound system issue.

    We sing, drum, guitar in our home, on Wiiiiiiiiiiiiiiiiiiii, and although there's a delay in the lyrics coming out of the speaker, they're not too loud.

    But not every system is the same... :(
  • aerofan11aerofan11 Unsigned
    edited October 2009
    I agree, it's very annoying. It doesn't happen on every song though, only the songs where the vocals are more quiet than usual (Come Together, for example).
    I hope they release an update to fix this.
  • ryan12147ryan12147 Headliner
    edited October 2009
    This glitch pisses me off, I can only sing when there's nobody home because my singing voice is awful. :p
  • NumanoidNumanoid Opening Act
    edited October 2009
    I wouldn't be able to sing without hearing my voice. It's much easier to pitch match the vocal track when it's coming from the same source.

    I have noticed that TBRB is very sensitive when it comes to the mics. On our first night we played the game with the same settings we play RB2 with and got some serious feedback when singing. We turned down the volume a bit.
  • JamstruthJamstruth Opening Act
    edited October 2009
    Am I the only person who doesn't know what the problem is? When I'm singing I don't hear my own voice coming loudly through the speakers, I mainly hear the Beatles vocal track coming through loud and clear and have changed none of the settings.
  • EhfahqEhfahq Headliner
    edited October 2009
    Jamstruth;3127277 said:
    Am I the only person who doesn't know what the problem is? When I'm singing I don't hear my own voice coming loudly through the speakers, I mainly hear the Beatles vocal track coming through loud and clear and have changed none of the settings.
    I dont have this problem either. I have it on Xbox, and play it on a CRT TV w/ no extra sound system.
  • JamstruthJamstruth Opening Act
    edited October 2009
    Ehfahq;3127406 said:
    I dont have this problem either. I have it on Xbox, and play it on a CRT TV w/ no extra sound system.
    I am similar. I play on Xbox like you but play on a LCD TV with a pair of 2.1 speakers plugged into the line out port of my TV (I need my subwoofer). I'm sure my voice is there but I only ever hear it during the freestyle sections if I shout to activate star power.
  • mansanomansano Unsigned
    edited October 2009
    Yeah, I have the same problem here too (I'm on the PS3). I can hear myself singing through the TV audio. It's WAY MUCH BETTER like RB2 where I can completely mute so the sound of voice won't come out from the TV too.

    PLZ HMX FIX THIS!!!!
  • Razorhoof78Razorhoof78 Opening Act
    edited October 2009
    I'm on Ps3 and I'm having the same problem. It helps if I turn the sensitivity up a bit and sing away from the mic, but I can always hear my voice drowning out the recordings. I am no Paul McCartney...
  • dragonflyrdragonflyr Rising Star
    edited October 2009
    interesting .. a lot of ps3 users having this issue.

    i was also getting a lot of feedback (NEVER had a feedback issue with rb2). had to re-position the singer, turn down mic sensativity, and turn down mic volume. managed to get feedback under control, but still vocals are loud.

    play RB2 all the time, and do not have this problem at all... RB2 is perfect. very easy for the singer to turn themselves up or turn themselves down ... no prob at all. i just can't seem to get the beatles vocal volumes correct. it's a drag!!!
  • master2uallmaster2uall Back From The Dead
    edited October 2009
    same damn problem here, wish it was fixed, but the fan boys here all just believe this game is just perfect, so until they finally wake up and admit that the game does have some issues, we won't get anything fixed at all.

    on a side note, looks like is a ps3 thing I guess, which doesn't surprise me, since we got shaky arrow, and 360 didn't, almost like they always hamper the ps3 version or something.
  • hannie3000hannie3000 Rising Star
    edited October 2009
    I'm on 360 and I also get this quite a lot. It's really annoying cos I don't like hearing myself sing Octopus' Garden an octave higher.. it just.. no.
  • babcarronbabcarron Unsigned
    edited November 2009
    We have the same problem here and we're refusing to purchase any Beatles DLC until a patch or something is worked out where the singer's volume can be adjusted. We've tried all settings, and can still hear the singer's voice loud and distorted even. No such problem exists for us on RB2. Please work on this!!!
  • TokelosheTokeloshe Unsigned
    edited December 2009
    I can't believe they haven't pushed out a patch to make it an option to completely mute the mic volume, or at least make the "low" volume go lower, with mic volume and sensitivity on 0% I still have trouble with the harmonies because I'm so loud! I mean it's cool to hear yourself but not when "low" volume is the same as 50% on rockband 2...
Sign In or Register to comment.