Magma error: "[idle] at $time occurs before beat 2"

buckaroobartbuckaroobart Unsigned
edited October 2009 in The Rock Band Network
30 hours later of sequencing, hacking, and generally tweaking the levels and I've almost got Magma exporting the compiled MIDI properly except that it throws this bizarre error: "[idle] at 3:1:000 occurs before beat 2". The very strange thing is that this occurs on the GUITAR track, but my moving the guitar [play] around I can get it to throw this error on all tracks.

The inconsistent throwing of this error makes me think that this error is misleading and that it may be a different problem. I do believe I have the tracks set up correctly, but there's something about the idle/play/etc. text events that are throwing the whole thing out of whack. I've tried removing all the text events except those that are absolutely required (drum mix, lyrics, the 3 EVENTS text events and the track names), but it doesn't seem to help.

Any thoughts?

Comments

  • buckaroobartbuckaroobart Unsigned
    edited October 2009
    Replying to my own thread, but perhaps this will help someone. I fixed this by setting BEAT notes starting from the very beginning of the track. I previously had the BEAT track start on measure 3, where the music actually begins with a pick-up on 3:4. *shrug*
  • socrstoprsocrstopr Opening Act
    edited October 2009
    It's OK to have the beat notes going from start to finish, and I'm pretty sure after seeing this that it's necessary :) Your characters default to [idle_realtime] meaning they are not tied to the beat until you stick another event in, such as [idle] or [play], so having the beat markers start earlier won't mess up the animations at all. Glad you figured it out, I would not have guessed that!
Sign In or Register to comment.