Audition Mode Trouble, "Network Polling Failure"

acralityacrality Unsigned
edited January 2011 in The Rock Band Network
Hey guys, just looking for some help with this problem I've been having for a while now.

Basically, every time I load up audition and try to transfer the song into my 360 I get an error saying "Network Polling Error". Here's a pic:

image

I've honestly tried everything I can think of.

- Opened NAT or whatever (all ports forwarded and whatnot)
- Set up static ip's for every computer on network
- Ran 360 on both wireless network and straight into router
- Multiple RBA's
- Reinstalls of Magma and XNA
- Different computers

Any suggestions on fixing this would be awesome, as I'm really eager to actually play test some of these songs.

Comments

  • davidshekdavidshek Community Playtester
    edited October 2009
    2 questions:

    1) Is your Xbox currently On, and running Rock Band 2, and in Audition Mode? If not, Magma can't transfer to it.

    2) Are you in Europe or some other region that uses PAL versions of RB2? If so, Magma until recently did not work with PAL RB2. They newest version, just released today, does. Download and install that.
  • trg007trg007 Your Ever Rocking RBN Forum Guru
    edited October 2009
    davidshek;3193171 said:
    2) Are you in Europe or some other region that uses PAL versions of RB2? If so, Magma does not currently work with PAL RB2.
    Actually it does, as of about 30 minutes ago! :)

    http://www.rockband.com/forums/showthread.php?t=170676
  • davidshekdavidshek Community Playtester
    edited October 2009
    trg007;3193174 said:
    Actually it does, as of about 30 minutes ago! :)
    Which is why I edited my post before you even posted that ;)
  • trg007trg007 Your Ever Rocking RBN Forum Guru
    edited October 2009
    Nice one! A flawlessly-executed ninja edit.
  • acralityacrality Unsigned
    edited October 2009
    davidshek;3193171 said:
    2 questions:

    1) Is your Xbox currently On, and running Rock Band 2, and in Audition Mode? If not, Magma can't transfer to it.

    2) Are you in Europe or some other region that uses PAL versions of RB2? If so, Magma until recently did not work with PAL RB2. They newest version, just released today, does. Download and install that.
    1. Haha, yes, my Xbox is definitely on and in Audition mode. Magma even recognizes it as being on and knows I'm logged in. It just won't transfer the song.

    2. I'm in America, so this definitely isn't it. Also tried with the newest version of Magma (that just released) and I still have nothing.
  • HMXMister_GameHMXMister_Game Harmonix Developer
    edited October 2009
    From our network programmer, can you try using the command line to transfer the song?

    - From a command prompt (Start Menu -> Run -> "Command"), cd to the installed Magma directory (eg: c:/Program Files/Harmonix Music Systems/Magma).

    - From there, first try running “MagmaTransfer_r.exe” – it should discover your Xbox waiting in audition mode (eg: “acrality”). From your screenshot, it appears this part should already be working.

    Next, try transferring the .rba or .rbs file with the full path, for example:
    MagmaTransfer_r.exe acrality “C:\Users\John Smith\Song Files\This_is_my_song.rba”
    (The quotes are only needed if there are spaces in the path name.)

    This may give you more information about why it's failing.
  • acralityacrality Unsigned
    edited October 2009
    HMXMister_Game;3194861 said:
    From our network programmer, can you try using the command line to transfer the song?

    - From a command prompt (Start Menu -> Run -> "Command"), cd to the installed Magma directory (eg: c:/Program Files/Harmonix Music Systems/Magma).

    - From there, first try running “MagmaTransfer_r.exe” – it should discover your Xbox waiting in audition mode (eg: “acrality”). From your screenshot, it appears this part should already be working.
    I'm apparently having trouble here.

    image

    It won't let me use the cmd prompt to run it. I tried both the MagmaTransfer.exe and the MagmaTransfer_r.exe.

    The MagmaTransfer.exe keeps giving me an error saying that I'm missing the audition.dta file, that should be in a config folder I don't have. I've tried redownloading/installing multiple times and never got it. Should I have this?

    The MagmaTransfer_r.exe just won't run for me. The file size says it is 0 kb, and every reinstall has said the same. Should this be bigger than that?
  • HMXMister_GameHMXMister_Game Harmonix Developer
    edited October 2009
    The first thing you need to do is change your working directory to the same directory as the Magma executable. On my computer, for example, the first command I would type in on the command line would be

    cd "C:\Program Files\Harmonix Music Systems\Magma\"
  • acralityacrality Unsigned
    edited October 2009
    Hopefully this just makes me look like a big idiot and is easily fixable:

    image

    In case the picture doesn't show up for whatever reason, just a bunch of lines saying
    "Connecting....Connecting to 0.116.75.0 port 1000"

    then >>Host Unreachable<<
    FAILURE: Network Polling Failure
  • HMXMister_GameHMXMister_Game Harmonix Developer
    edited October 2009
    Is this after you have run MagmaTransfer_r.exe to discover your xbox?
  • acralityacrality Unsigned
    edited October 2009
    This is after using just MagmaTransfer.exe

    MagmaTransfer_r.exe still gives me an error saying that it isn't a valid Win32 application.

    MagmaTransfer.exe did recognize my xbox, though. It just won't transfer/connect to transfer after it finds it.
  • HMXMister_GameHMXMister_Game Harmonix Developer
    edited October 2009
    Sorry, the _r is a typo, take it out. Check out your Magma directory, the executable you need is just named "MagmaTransfer.exe"

    So you get the "Host Unreachable" error after successfully discovering your xbox, and then attempting to transfer?
  • acralityacrality Unsigned
    edited October 2009
    Yeah, that is correct.

    Don't know if it's worth noting or not, but the numbers before the port (with all the decimal points, maybe an ip address?) changed every time I ran it. The port number, however, stayed the same.
  • davidshekdavidshek Community Playtester
    edited October 2009
    acrality;3197446 said:
    Yeah, that is correct.

    Don't know if it's worth noting or not, but the numbers before the port (with all the decimal points, maybe an ip address?) changed every time I ran it. The port number, however, stayed the same.
    Yes, those numbers would be an IP address, and should be the IP address of your Xbox. Needless to say, "0.116.75.0" is most likely NOT the correct IP of your Xbox.
  • acralityacrality Unsigned
    edited October 2009
    So... how would I make it so that the ip does match?
  • HMXMister_GameHMXMister_Game Harmonix Developer
    edited November 2009
    I’ve been following the updates on this thread, and the output you are describing:
    "Connecting....Connecting to 0.116.75.0 port 1000
    Connecting....Connecting to 0.116.75.0 port 1000
    Connecting....
    >>>>> Host unreachable! <<<<<
    FAILURE: Network polling failure"

    means your discovery is succeeding and finding his Xbox, but establishing a transfer connection is failing. The ip address displayed is correct for this situation, and the behavior of it changing each time is also expected.
  • TrueRipperTrueRipper Unsigned
    edited January 2010
    So what should be done to make the Failure stop happening?
    I get to:
    ">>>>> Host unreachable! <<<<<
    FAILURE: Network polling failure"
  • havityourwaybkzhavityourwaybkz Unsigned
    edited January 2010
    Me too, hence my other thread. I'm really anxious to try out some songs, so Id really appreciate some help :)
  • boblybobboblybob Opening Act
    edited February 2010
    Yeah, I am really desperate to get this solved, there has to be a solution.

    Anyone, please?
  • OhioBuckeyeOhioBuckeye Opening Act
    edited February 2010
    Ok I don't believe 0.116.75.0 is a valid IP address. And he states it keeps changing. Can you provide us what the correct IP address is for your xbox itself? You should be able to obtain this under settings/network. I think that's the first step to at least verify you have an active IP address.

    If so then we can attempt to do a telnet test from your Windows host that contains magna.
  • aander91aander91 Opening Act
    edited January 2011
    SOLVED!

    -Disable Hamachi adapter or any other network adapters besides LAN and the one you're getting internet from
    -Disable Firewall

    Then this is what fixed it:
    Go to Network Connections, select the adapter that is giving you internet and click Change Settings of this Adapter. Check ONLY THESE BOXES:
    -Client for Microsoft Networks
    -Microsoft Network Monitor 3 Drive
    -Internet protocol Version 4 (I'm pretty sure 6 is what was blocking it)
    -Both the Link Layer TD Mapper and Responder

    Then it should work. Not sure why, I sort of got lucky here I guess.
Sign In or Register to comment.