Screen Lag in Rock Band Beatles

WoozayayaWoozayaya Unsigned
edited December 2009 in The Beatles: Rock Band
Hi Guys, I just bought Rock Band Beatles and I've noticed that my screen lags sometimes during the songs. When I say lag I mean that the notes bekom blurry, it's kind of hard to explain but I can post a link to a video where I can display my problem.

But from my short description, does anybody know what the problem is and what the solution is?

I have an LCD-TV Samsuns LE40FBDX (I think that was the model numer) with 100hz motion plus FullHD (Not that it matters but yeh).... So it's not a crappy TV. Now I'm thinking if this can happen if you have a bad cable, because my HDMI-cable is old and cheaper than a cheeseburger.

Happy for some help!

Comments

  • Explosion2Explosion2 Road Warrior
    edited December 2009
    I think a video would be helpful. I think I understand what you're describing, but I haven't heard of this problem before. I think a video would ensure what is happening is what I'm thinking of.
  • WoozayayaWoozayaya Unsigned
    edited December 2009
    Alrighty, video is coming up soon, just wait a moment.
  • mywhitenoisemywhitenoise Rising Star
    edited December 2009
    I have the same problem when I play single player, but its pretty much gone when I play multiplayer.

    Do you play on PS3 or 360? Im on PS3, and my friend had the same problem on 360 until he switched from HDMI to VGA.
  • WoozayayaWoozayaya Unsigned
    edited December 2009
    I play on PS3 and I don't have the same problem on Rock Band 2. I first recognized the problem when I started playing Band Hero, but thought that it was due to the game... But clearly it isn't.
  • WoozayayaWoozayaya Unsigned
    edited December 2009
    Here is a video of my problem, I hope you can see it.... My camera isn't that good.

    Link: http://www.youtube.com/watch?v=GAIVku4cTFo
  • danya101danya101 Unsigned
    edited December 2009
    My screen lagged just after i re calibrated it
    when in game i would hit the note perfectly, and get it
    i could hit it a little bit after (like the distance of a note) and STILL get it
    but if i hit it even a little bit before, i wouldnt get it (really bad because i tend to hit my notes a little early)
    so i manually set my delay down 20 ms and that did the trick
  • WoozayayaWoozayaya Unsigned
    edited December 2009
    danya101;3389582 said:
    My screen lagged just after i re calibrated it
    when in game i would hit the note perfectly, and get it
    i could hit it a little bit after (like the distance of a note) and STILL get it
    but if i hit it even a little bit before, i wouldnt get it (really bad because i tend to hit my notes a little early)
    so i manually set my delay down 20 ms and that did the trick
    Yes but you seem to have a difference between when the sound is played and when the note is displayed, I don't have that problem, my problem is that my notes get blurry and kind of "slow down"...
  • danya101danya101 Unsigned
    edited December 2009
    Woozayaya;3389589 said:
    Yes but you seem to have a difference between when the sound is played and when the note is displayed, I don't have that problem, my problem is that my notes get blurry and kind of "slow down"...
    no, the audio was completely perfect, i adjusted the video delay and it worked perfectly
  • MostSpartan14MostSpartan14 Road Warrior
    edited December 2009
    Woozayaya;3389574 said:
    Here is a video of my problem, I hope you can see it.... My camera isn't that good.

    Link: http://www.youtube.com/watch?v=GAIVku4cTFo
    I have the exact same problem. It doesn't happen as often as it did with you but it does happen to me every once in a while. The odd thing is that other games like Call of Duty and GTA4 don't lag at all for me. It only happens with any rhythm game (Rock Band AND Guitar Hero games). I think it may have to do with playing on an HD TV but I really have no idea why it does this.
  • danya101danya101 Unsigned
    edited December 2009
    oh, after watching the video in HD and for the third time, i finally see what the problem is
    you could try switching to a component cable (still HD and you will probably not notice the difference, except the lag might go away)
    or you could try lowering the resolution to 1080i or 720p
  • WoozayayaWoozayaya Unsigned
    edited December 2009
    MostSpartan14;3389600 said:
    I have the exact same problem. It doesn't happen as often as it did with you but it does happen to me every once in a while. The odd thing is that other games like Call of Duty and GTA4 don't lag at all for me. It only happens with any rhythm game (Rock Band AND Guitar Hero games). I think it may have to do with playing on an HD TV but I really have no idea why it does this.
    I completly agree with you there, In demanding games, such as Uncharted 2, Modern Warfare 2.. Everything looks great, but in Band Hero and RB Beatles it gives me a lag...

    But the weirdest part is that this doesn't happen in Rock band 2.
    Why is this?
  • danya101danya101 Unsigned
    edited December 2009
    is your disc damaged/scratched in any way?
  • WoozayayaWoozayaya Unsigned
    edited December 2009
    danya101;3389659 said:
    is your disc damaged/scratched in any way?

    Bought it today, opened it a few hours ago, and it's not the games fault because, as I said before, this has happened in Band Hero as well, so there is something i have to do hardwarewise or maybe calibrate or change some settings....

    Now what I have to do, I have no idea.
  • danya101danya101 Unsigned
    edited December 2009
    again, try changing the resolution to 1080i or 720p
  • Explosion2Explosion2 Road Warrior
    edited December 2009
    Hmm... That's odd. I wish I could help more than say what was said before.
    Try changing to component and/or switching your system's resolution.

    also, (this is just a wild shot in the dark, but you might as well) try "video overscan" in the options menu. I believe it is to increase the size of the picture to fill the TV, but try it and see if it does anything.
  • WoozayayaWoozayaya Unsigned
    edited December 2009
    Explosion2;3389982 said:
    Hmm... That's odd. I wish I could help more than say what was said before.
    Try changing to component and/or switching your system's resolution.

    also, (this is just a wild shot in the dark, but you might as well) try "video overscan" in the options menu. I believe it is to increase the size of the picture to fill the TV, but try it and see if it does anything.
    Hey, I tried the Overscan thing and it didn't help me at all, thanks for suggesting it though, it sounded like it could've been somehting that could help me.

    If i change the resolution, hmm that could work, because these games are made in 720, and I use 1080, could that be the problem perhaps?
  • danya101danya101 Unsigned
    edited December 2009
    Woozayaya;3390153 said:
    Hey, I tried the Overscan thing and it didn't help me at all, thanks for suggesting it though, it sounded like it could've been somehting that could help me.

    If i change the resolution, hmm that could work, because these games are made in 720, and I use 1080, could that be the problem perhaps?
    hmm could it work?
    i dont know why dont you TRY IT *facepalm*
  • CCDaDonCCDaDon Headliner
    edited December 2009
    You should read the back of the case before playing games. If they don't support 1080p then you should change your settings to allow it to play in the resolutions it does support. The back of the case, that I have right here in my hand, says 720p.
  • WoozayayaWoozayaya Unsigned
    edited December 2009
    danya101;3390403 said:
    hmm could it work?
    i dont know why dont you TRY IT *facepalm*
    Yeh well facepalm yourself, I was not home at the moment so it was hard to TRY IT then, that's why I wanted to continue this discussion so someone that maybe knew what if that was the problem could jump in.

    Anyway I'm going to try if out know.

    EDIT: I changed the resolution to 720p but it didn't help unfortunately...
  • kenttzkenttz Unsigned
    edited December 2009
    Have you turned off auto motion? I have a Samsung also with 120hz auto motion and have notice something similar to what you are describing just not as bad or frequent and I did turn it off and it seemed to calm it down alittle but its still there.
  • MarioUKMarioUK Unsigned
    edited December 2009
    kenttz;3391721 said:
    Have you turned off auto motion? I have a Samsung also with 120hz auto motion and have notice something similar to what you are describing just not as bad or frequent and I did turn it off and it seemed to calm it down alittle but its still there.
    This is actually a very good suggestion, a lot of modern TVs have all sorts of bells and whistles that do things to the picture, auto-motion, cinema mode, 100Hz, artefact reduction etc etc, which is why a lot of TVs also have a Game Mode to switch off all the clever stuff and just leave the native picture.
Sign In or Register to comment.