Error involving [idle] that hasn't been answered before

Shadow2222Shadow2222 Opening Act
edited February 2010 in The Rock Band Network
...at least to my knowledge. I have, with the permission of the chart author, and with my own MP3, been trying to make a custom from a Frets on Fire chart just to get the basics of Reaper/Magma.

I have got everything working (I think) except for a pesky [idle] error ([idle] at 1:1:000 occurs before beat 2).

I am not trying to get the animations working, since this is just a test of the actual song making/audition process.

I've read the tips on [idle] errors and nothing works, so I wanted to provide the midi file to see if anyone can help. I would appreciate if you would fix it for me, but regardless, tell me how to do it so I know in the future. Thanks

http://www.zshare.net/audio/716442994fe902b0/

Comments

  • trg007trg007 Your Ever Rocking RBN Forum Guru
    edited January 2010
    Shadow2222;3455745 said:
    ...at least to my knowledge. I have, with the permission of the chart author, and with my own MP3, been trying to make a custom from a Frets on Fire chart just to get the basics of Reaper/Magma.

    I have got everything working (I think) except for a pesky [idle] error ([idle] at 1:1:000 occurs before beat 2).

    I am not trying to get the animations working, since this is just a test of the actual song making/audition process.

    I've read the tips on [idle] errors and nothing works, so I wanted to provide the midi file to see if anyone can help. I would appreciate if you would fix it for me, but regardless, tell me how to do it so I know in the future. Thanks

    http://www.zshare.net/audio/716442994fe902b0/
    Change it to an [idle_realtime] and you will be all set. [idle] makes a character move to the beat while they're not playing, but you can't have them moving to the beat if the beat hasn't started yet (hence that error :)).
  • Shadow2222Shadow2222 Opening Act
    edited January 2010
    Thanks for the help, but I tried putting in [idle_realtime], but it didn't do anything (I'm still getting that same error). It must be something I am doing, but I can't for the life of me figure out what else could cause that error (it is pretty specific, after all).

    EDIT: also, and I'm not sure it makes a difference, I never had an idle event in the first place. I only just added the [idle_realtime] that was suggested, as I had nothing to change
  • trg007trg007 Your Ever Rocking RBN Forum Guru
    edited January 2010
    Shadow2222;3455875 said:
    Thanks for the help, but I tried putting in [idle_realtime], but it didn't do anything (I'm still getting that same error). It must be something I am doing, but I can't for the life of me figure out what else could cause that error (it is pretty specific, after all).

    EDIT: also, and I'm not sure it makes a difference, I never had an idle event in the first place. I only just added the [idle_realtime] that was suggested, as I had nothing to change
    Sometimes there are strange Reaper bugs that cause "phantom events" or "phantom notes" that you can't see anywhere in the interface.

    In this case, open a new RBNTemplate and copy your guitar notes into it, then try building from that.
  • Shadow2222Shadow2222 Opening Act
    edited January 2010
    Oh wow, I can't believe I didn't think of that! Thanks very much, that solved my issue!
  • Shadow2222Shadow2222 Opening Act
    edited February 2010
    Even though that worked for that particular song, I went to try to convert more songs today, and I'm getting an [idle] error for every song. I don't know what I'm doing. Its the only error I am getting.

    I have tried starting over multiple times, and simply copying over one or more of my already completed tracks from one project to another.

    Nothing works. I am truly at a loss. I am not doing true animations at the moment, so I don't even have any [idle]/[play]/etc commands.

    Please help
Sign In or Register to comment.