Problems With Magma/Reaper

CJCOLDCJCOLD Unsigned
edited February 2010 in The Rock Band Network
This is the error

Build started at 3:37 AM.
Reading the archive
Project Compiler: Reading project 'C:\Users\Administrator\Documents\untitled.lol.rbproj'...
Project Compiler: Entering Phase 1 of 6...
Metadata Compiler: Starting...
Metadata Compiler: Done.
Project Compiler: Entering Phase 2 of 6...
MIDI Compiler: Starting...
ERROR: MIDI Compiler: c:/users/administrator/desktop/midi_export.mid (PART DRUMS): drum mix 'drums3easynokick' at 1:1:060 supports exactly 6 (total) drum channels; this song's configuration has 2 (total) drum channels
ERROR: MIDI Compiler: c:/users/administrator/desktop/midi_export.mid (PART DRUMS): drum mix 'drums3easynokick' at 1:1:060 supports exactly 2 kick channels; this song's configuration has 0 kick channels
ERROR: MIDI Compiler: c:/users/administrator/desktop/midi_export.mid (PART DRUMS): drum mix 'drums3easynokick' at 1:1:060 supports exactly 2 snare channels; this song's configuration has 0 snare channels
ERROR: MIDI Compiler: c:/users/administrator/desktop/midi_export.mid (PART DRUMS): drum mix 'drums3' at 1:1:120 supports exactly 6 (total) drum channels; this song's configuration has 2 (total) drum channels
ERROR: MIDI Compiler: c:/users/administrator/desktop/midi_export.mid (PART DRUMS): drum mix 'drums3' at 1:1:120 supports exactly 2 kick channels; this song's configuration has 0 kick channels
ERROR: MIDI Compiler: c:/users/administrator/desktop/midi_export.mid (PART DRUMS): drum mix 'drums3' at 1:1:120 supports exactly 2 snare channels; this song's configuration has 0 snare channels
ERROR: MIDI Compiler: c:/users/administrator/desktop/midi_export.mid (PART DRUMS): drum mix 'drums3' at 1:1:180 supports exactly 6 (total) drum channels; this song's configuration has 2 (total) drum channels
ERROR: MIDI Compiler: c:/users/administrator/desktop/midi_export.mid (PART DRUMS): drum mix 'drums3' at 1:1:180 supports exactly 2 kick channels; this song's configuration has 0 kick channels
ERROR: MIDI Compiler: c:/users/administrator/desktop/midi_export.mid (PART DRUMS): drum mix 'drums3' at 1:1:180 supports exactly 2 snare channels; this song's configuration has 0 snare channels
ERROR: MIDI Compiler: c:/users/administrator/desktop/midi_export.mid (PART DRUMS): drum mix 'drums3' at 1:1:240 supports exactly 6 (total) drum channels; this song's configuration has 2 (total) drum channels
ERROR: MIDI Compiler: c:/users/administrator/desktop/midi_export.mid (PART DRUMS): drum mix 'drums3' at 1:1:240 supports exactly 2 kick channels; this song's configuration has 0 kick channels
ERROR: MIDI Compiler: c:/users/administrator/desktop/midi_export.mid (PART DRUMS): drum mix 'drums3' at 1:1:240 supports exactly 2 snare channels; this song's configuration has 0 snare channels
ERROR: MIDI Compiler: c:/users/administrator/desktop/midi_export.mid (EVENTS): [play] event at 7:1:000 is not allowed
ERROR: MIDI Compiler: c:/users/administrator/desktop/midi_export.mid (EVENTS): [music_start] event is required but not found
ERROR: MIDI Compiler: c:/users/administrator/desktop/midi_export.mid (EVENTS): [music_end] event is required but not found
ERROR: MIDI Compiler: c:/users/administrator/desktop/midi_export.mid (EVENTS): [end] event is required but not found
MIDI Compiler: Done.
ERROR: Project Compiler: Midi compiler failed.
Build ended at 3:37 AM.

Pictures welcome to help me understand better what i need to do

What do i need to do to fix this? (NOTE: Drum only chart if that makes a difference)

Thanks in advance

Comments

  • TheOzoneTheOzone Road Warrior
    edited January 2010
    I'll comment on the problems I know.

    ERROR: MIDI Compiler: c:/users/administrator/desktop/midi_export.mid (EVENTS): [play] event at 7:1:000 is not allowed
    The "[play]" event is only for the VOCALS, GUITAR, BASS, and DRUMS MIDI tracks. It's sets that instrument's character to do the "play" set of animations.
    ERROR: MIDI Compiler: c:/users/administrator/desktop/midi_export.mid (EVENTS): [music_start] event is required but not found
    You need a "[music_start]" text event in your EVENTS MIDI track to tell the game when the song starts playing.
    ERROR: MIDI Compiler: c:/users/administrator/desktop/midi_export.mid (EVENTS): [music_end] event is required but not found
    You need a "[music_end]" text event in your EVENTS MIDI track to tell the game the song is over.
    ERROR: MIDI Compiler: c:/users/administrator/desktop/midi_export.mid (EVENTS): [end] event is required but not found
    You need an "[end]" text event in your EVENTS MIDI track to tell the game when to end the song and take you to the results screen

    As for the other errors, why are there more than one drum mix? I don't even know why there's one called "drum3easynokick". I believe there should only be one mix on your DRUMS track. And the reason it's saying there's 0 channels is you don't have the stems active. You need: a snare stem (stereo), a kit stem (stereo), and a kick stem (mono).
  • CJCOLDCJCOLD Unsigned
    edited January 2010
    EDIT 2:

    Ok i fixed everything but this now

    Build started at 5:24 PM.
    Reading the archive
    Project Compiler: Reading project 'C:\Users\*****\*****\untitled.rbproj'...
    Project Compiler: Entering Phase 1 of 6...
    Metadata Compiler: Starting...
    Metadata Compiler: Done.
    Project Compiler: Entering Phase 2 of 6...
    MIDI Compiler: Starting...
    ERROR: MIDI Compiler: c:/users/*****/*****/linkin park - nobody's listening.mid: Track PART DRUMS required but not found
    ERROR: MIDI Compiler: c:/users/*****/*****/linkin park - nobody's listening.mid: Halting compilation due to missing and/or extraneous MIDI tracks
    MIDI Compiler: Done.
    ERROR: Project Compiler: Midi compiler failed.
    Build ended at 5:24 PM.

    That's the only error message i get now, picture is here image

    What Do?
  • trg007trg007 Your Ever Rocking RBN Forum Guru
    edited January 2010
    Linkin Park? Somehow I doubt you have the rights to author that song.

    Check your PART DRUMS event and make sure it's set as a "Track Name" type and not "Text Event" or something else. Also, make sure there is only one PART DRUMS event in the track; if there's a second one hiding somewhere else in the track it will mess things up. Finally, make sure your drum MIDI track is not muted in Reaper. When you export the MIDI, Reaper ignores any MIDI tracks that are muted.
  • CJCOLDCJCOLD Unsigned
    edited January 2010
    Yet another problem...

    I added PART DRUMS as the track name and now Magma is giving me all these errors

    Saving unsaved changes before build.
    Build started at 9:00 PM.
    Reading the archive
    Project Compiler: Reading project 'C:\Users\Administrator\Documents\untitled.lol.rbproj'...
    Project Compiler: Entering Phase 1 of 6...
    Metadata Compiler: Starting...
    Metadata Compiler: Done.
    Project Compiler: Entering Phase 2 of 6...
    MIDI Compiler: Starting...
    ERROR: MIDI Compiler: c:/users/administrator/desktop/lp - nobody's listening.mid (PART DRUMS): improperly formatted mix event '[mix drums0]' at 1:1:060
    ERROR: MIDI Compiler: c:/users/administrator/desktop/lp - nobody's listening.mid (PART DRUMS): No drum submix specified for difficulty 0 before first gem at 6:3:000
    ERROR: MIDI Compiler: c:/users/administrator/desktop/lp - nobody's listening.mid (PART DRUMS): No drum submix specified for difficulty 1 before first gem at 6:3:000
    ERROR: MIDI Compiler: c:/users/administrator/desktop/lp - nobody's listening.mid (PART DRUMS): No drum submix specified for difficulty 2 before first gem at 6:3:000
    ERROR: MIDI Compiler: c:/users/administrator/desktop/lp - nobody's listening.mid (PART DRUMS): No drum submix specified for difficulty 3 before first gem at 6:3:000
    ERROR: MIDI Compiler: c:/users/administrator/desktop/lp - nobody's listening.mid (PART DRUMS): No drum submix specified for difficulty 0
    ERROR: MIDI Compiler: c:/users/administrator/desktop/lp - nobody's listening.mid (PART DRUMS): No drum submix specified for difficulty 1
    ERROR: MIDI Compiler: c:/users/administrator/desktop/lp - nobody's listening.mid (PART DRUMS): No drum submix specified for difficulty 2
    ERROR: MIDI Compiler: c:/users/administrator/desktop/lp - nobody's listening.mid (PART DRUMS): No drum submix specified for difficulty 3
    ERROR: MIDI Compiler: c:/users/administrator/desktop/lp - nobody's listening.mid (PART DRUMS): [music_start] event at 2:3:000 is not allowed
    ERROR: MIDI Compiler: c:/users/administrator/desktop/lp - nobody's listening.mid (PART DRUMS): [music_end] event at 77:2:120 is not allowed
    ERROR: MIDI Compiler: c:/users/administrator/desktop/lp - nobody's listening.mid (PART DRUMS): [end] event at 77:2:120 is not allowed
    MIDI Compiler: Done.
    ERROR: Project Compiler: Midi compiler failed.
    Build ended at 9:00 PM.
  • NSIYusukeNSIYusuke Opening Act
    edited January 2010
    '[mix drums0]"

    That should be:

    '[mix 0 drums0]"
    and also have:
    "[mix 1 drums0]"
    "[mix 2 drums0]"
    "'[mix 3 drums0]"

    before the first drum note. I had a lot of problems like this when I was trying to export, too. but it gets easier, don't worry!
  • CJCOLDCJCOLD Unsigned
    edited February 2010
    NSIYusuke;3470354 said:
    '[mix drums0]"

    That should be:

    '[mix 0 drums0]"
    and also have:
    "[mix 1 drums0]"
    "[mix 2 drums0]"
    "'[mix 3 drums0]"

    before the first drum note. I had a lot of problems like this when I was trying to export, too. but it gets easier, don't worry!
    Thank You! this helped so much, now i have a bit of a sync problem but i can easily fix that, Once again, thank you all for the help.
Sign In or Register to comment.