problem buying rbn tracks directly from marketplace

jimburyjimbury Road Warrior
edited August 2010 in The Rock Band Network
i've been buying tracks directly from marketplace since pretty much the start of rbn, but for the last 3 days it won't let me, the message i get is...

Windows Live ID is unavailable from this site for one of the following reasons:

* This site may be experiencing a problem.
* The site may not be a member of Windows Live ID.

it then asks me to re-enter my password without giving me anywhere to do so.

is anyone else experiencing this problem? its not the end of the world because i can always wait til they're in the store proper, but i'm curious as to whether its a local problem or not

any advice gratefully received.

Comments

  • ThatAuthoringGroupThatAuthoringGroup Numero Uno Super **** Fanboy #1
    edited August 2010
    Yeah there seems to be a widespread problem, as I've read a lot of people are having trouble getting the RBN tracks the last few days.

    I'm guessing with HMX in Germany, there's not a lot of people manning the fort right now.

    So there's no one to go in and slap the server upside the head and get it sorted, I'd imagine.
  • jimburyjimbury Road Warrior
    edited August 2010
    ok thanks for the speedy response, i'll have some patience
  • SCFoxSCFox Opening Act
    edited August 2010
    Was just about to come here to post something similar. Glad to see it isn't just me.
  • XenigmaXenigma Opening Act
    edited August 2010
    Seems to be a bug with the whole Marketplace, and it can be at least temporarily fixed by clearing your cookies. Personally, I just bought some DLC through a browser I rarely use (since it would have few cookies) and it worked perfectly.
  • jimburyjimbury Road Warrior
    edited August 2010
    Xenigma;3956553 said:
    Seems to be a bug with the whole Marketplace, and it can be at least temporarily fixed by clearing your cookies. Personally, I just bought some DLC through a browser I rarely use (since it would have few cookies) and it worked perfectly.
    top advice, i did the same and its working perfectly thanks

    as an aside, internet explorer is slow and ugly, i'd forgotten how unwieldy it is.
  • SCFoxSCFox Opening Act
    edited August 2010
    Xenigma;3956553 said:
    Seems to be a bug with the whole Marketplace, and it can be at least temporarily fixed by clearing your cookies. Personally, I just bought some DLC through a browser I rarely use (since it would have few cookies) and it worked perfectly.
    Thanks, this actually solved my problem. Never thought I'd have a reason to use internet explorer again after getting Firefox.
  • XenigmaXenigma Opening Act
    edited August 2010
    SCFox;3957132 said:
    Thanks, this actually solved my problem. Never thought I'd have a reason to use internet explorer again after getting Firefox.
    It's not; I use Chrome as my backup. Who needs IE? :P
  • JL87 aka MaineJL87 aka Maine Opening Act
    edited August 2010
    I haven't had this lately (3 months), but I had this problem before. It was really annoying because I could log on to the site at my cousin's house, but not mines. I bout more RBN DLC from the online marketplace 2 days ago, and yesterday, and haven't had any problems.

    Edit* I did end up cleaning my computer, so that may have been what fixed it for me.
Sign In or Register to comment.