Rock Band 3 Well connected achievement not unlocking.

LundyLundy Unsigned
edited September 2013 in Peer To Peer Support Forum
So. for days now I've been linking and unlinking my account and waiting patiently for this thing to unlock, but no no luck. Finally I thought it might help if I connected at www.rockband.com/international, because I am from Canada, but still nothing. This is very frustrating. Is anyone else having this problem still?

Comments

  • Firestar-HartFirestar-Hart Unsigned
    edited November 2010
    I am. I've been waiting for 4 days & still no achievement. The RB3 team needs to fix this!
  • MinusTheBearMinusTheBear Opening Act
    edited November 2010
    I have the same problem, site says I'm linked. No achievement and my GS is for the first time ever not in an increment of 5 and I'm freaking out. I hate it. OCD kickin in so bad. 26504 is just so weird. I need that 6. HMX, why didn't you just make it 5 and 5? haha
  • BloodEyesDragonBloodEyesDragon Unsigned
    edited November 2010
    I don't know if it'll work for you guys, but here's what happened with me:

    1. Tried linking today. Like the rest of you, I didn't get the achievement.
    2. Exited to the Xbox dashboard and reloading the game.
    3. Once I got the main menu, the achievement unlocked.

    Hope that helps.
  • MinusTheBearMinusTheBear Opening Act
    edited November 2010
    I linked, and now it shows progress on RB.com, yet still no achievement.
  • darthsmurfxdarthsmurfx Opening Act
    edited November 2010
    That last digit that is neither a 5 nor a 0 is driving me up the wall... and this achievement REFUSES to unlock for me!!!! ARGH! Look... now I'm a pirate. Way to go, HMX. Now I have to go pillage a bit before I go back to work.
  • greeneyedgirl78greeneyedgirl78 Unsigned
    edited November 2010
    Same here, I'm at 32859 and I can't take it LOL!!!
  • SlashboiSlashboi Opening Act
    edited November 2010
    this worked like a charm for me. Thanks man.
  • darthsmurfxdarthsmurfx Opening Act
    edited November 2010
    This site is tracking my RB3 progress. I played for HOURS last night... everything I did shows up on this site... NO ACHIEVEMENT!!!! Argh! There... I'm a pirate again... thanks, landlubber.
  • EvolusEvolus Unsigned
    edited November 2010
    Same issue happening with me. Achievement isn't unlocking despite the website correctly tracking my progress. I've signed in and out of my Xbox dashboard again and again and still nothing.
  • OmegaOuterOmegaOuter Unsigned
    edited November 2010
    Not working for me either...
  • cybermouseycybermousey Unsigned
    edited November 2010
    Same deal. I was logged into live. got my code. Went online, linked it, and nothing happended on my Xbox. I even exited the game and came back in.
  • agentbishieagentbishie Unsigned
    edited November 2010
    Same problem with the Playstation Network on my side. I was linked with my Rockband 2 game though. Maybe this only works with a "first time linking" into the system? Was everybody else who is also having problems also linked with Rockband 2 first?
  • garnsrgarnsr Unsigned
    edited November 2010
    I'm on PS3, and I guess I must have linked on RB2, and I haven't gotten it, but it is tracking my gameplay. I don't know anything else I could try to get it to work, but I have seen notices here that some people got the achievement, so it's working for somebody.
  • XxIronManxX1XxIronManxX1 Unsigned
    edited November 2010
    I did that w/ no luck.
  • WeepingWillowWeepingWillow Unsigned
    edited November 2010
    I also had my account linked from the RB2 days, there isn't even an option anymore to link the RB3 code.

    No achievement for me either.
  • hydroxydehydroxyde Unsigned
    edited November 2010
    Had my account linked for weeks now. Progress is shown on site, no achievement in game. I've tried entering the code on the site multiple times, each time it says that I've unlocked the "Well Connected" achievement. Lies.
    Normally, this wouldn't be a huge problem, but some fool over there decided to make 4/6 point achievements. I guess because they know a lot of people hate having scores that don't end in 0 or 5.
    Well, if you're going to be horrible people and do something like that, you could at least make it work properly.
  • litlnemolitlnemo Unsigned
    edited November 2010
    It's not working for me, either. And I also had my account connected for RB2.
  • sleepynowsleepynow Unsigned
    edited November 2010
    Same thing here. It took forever to be able to link, and it shows I'm linked and it tracks my progress etc, but no achievement. I've done all the trouble shooting but it just won't work. WTF??? I'm kinda frustrated because it's such a stupid thing to complain about, but here I am, complaining about a 6 point achievement....somebody just figure this out already....
  • sleepynowsleepynow Unsigned
    edited November 2010
    Sorry for the double post- It literally just unlocked. When it says Press Start, I usually hit the green button. This time I pressed start, and there it is! Pretty lame if that was what the problem was....expecting rock stars to follow instructions...
  • Live4HaloLive4Halo Unsigned
    edited November 2010
    I just unlinked and relinked my game a few times. After that when I entered the menu, I gained the achievement on both mine and my brother's account.

    Try unlinking and relinking a few times and then restarting, it might help.
  • ponypo2001ponypo2001 Unsigned
    edited November 2010
    You're all so damn lucky. I cannot relink my damn game at all. Constantly get the message my code is already in use. I've never had my stats on the site for RB3 but had no trouble linking RB2 ages ago. How on Earth am I supposed to put a new code in when my game only spits the same code out every time. Harmonix clearly don't give a crap either as they won't respond to email or posts on the forum. I'm literally tearing my hair out over this.
  • lincsflierlincsflier Unsigned
    edited November 2010
    If you unlink any code but then link your new code using the support link on the left. On that page is a button that says Get Career Goal then that should work next time you start the game again. Found that the link page wouldn't work but that one did.

    Hope it helps.
  • darthsmurfxdarthsmurfx Opening Act
    edited November 2010
    I unlinked my account, relinked, loaded up RB3 and poof... achievement unlocked. FINALLY.
  • MinusTheBearMinusTheBear Opening Act
    edited November 2010
    Same as above, without even unlinking, I loaded it up just now, and got the achievement. Ahhhh back to an good score.
  • TriviumKillsTriviumKills Unsigned
    edited November 2010
    Please fix!!!!!! The 9 at end of game score is not right! 40469 lol 69
  • IISHIZNITSIIIISHIZNITSII Unsigned
    edited November 2010
    ponypo2001;4176619 said:
    You're all so damn lucky. I cannot relink my damn game at all. Constantly get the message my code is already in use. I've never had my stats on the site for RB3 but had no trouble linking RB2 ages ago. How on Earth am I supposed to put a new code in when my game only spits the same code out every time. Harmonix clearly don't give a crap either as they won't respond to email or posts on the forum. I'm literally tearing my hair out over this.
    you need to log into this site with the email and password you used when you registered your RB2.. Your code that you are entering is not needed if you've already done RB2...
  • Slambo239Slambo239 Unsigned
    edited November 2010
    I have got to ask...what is the big deal with the scores not ending in a 0 or 5? I dont believe i have ever paid attention to that nor would i have cared. Does this affect game play in any way? Does it have a negative affect in rankings? If these answers are both no, then i really dont get it.
  • IISHIZNITSIIIISHIZNITSII Unsigned
    edited November 2010
    Slambo239;4181101 said:
    I have got to ask...what is the big deal with the scores not ending in a 0 or 5? I dont believe i have ever paid attention to that nor would i have cared. Does this affect game play in any way? Does it have a negative affect in rankings? If these answers are both no, then i really dont get it.

    its all personal preference. some people care and some just dont. I for one cannot stand my GS to end in anything but a 0 or 5, but thats just me.
  • BrainwreckedTechBrainwreckedTech Unsigned
    edited November 2010
    Came to rockband.com to enter the linking code and found out that I was already linked up from the RB2 days. Tried to unlink and then re-link, then exited to dashboard and restart. No dice. Then I went back to the dashboard actually pressed start at the main screen. HOE LEE SHEET. Really? Seriously? THAT'S what needed to be done?


    That's 3 bugs now...I've managed to crash RB3 (and made the 360 unresponsive to anything but the power button) trying to exit back to a road challenge, I've had an accuracy gauge that refused to fill up (though the game was keeping track of it and handing out spades accordingly) and now this.
  • JackBNimbleJackBNimble Road Warrior
    edited November 2010
    That's funny, I never even tried linking the game and it's tracking my progress. Although I did link RB2 so I suspect it just carried over.
Sign In or Register to comment.