New Bugs and Issues

edited December 2007 in Announcements
So this afternoon Greg flipped the switch on the new vBulletin forums for the site. Immediately the performance of the site got way better. Yay! There probably are a few bugs here and there due to migrating everything over and getting it working. Feel free to post them here.

Comments

  • edited April 2007
    xarexerax;1435 said:
    ...One small thing though, I keep getting kicked out to the login page and then it won't load the "You have logged in" thing ... so ... I don't know, I still seem to be able to post, but it is confusing to me when it keeps asking me who I am when I've already told it. Just a small little thing really since it doesn't seem to be interefering.
    It's a cookie setting in this software plus some links use www. in front of rockbandgame.com.
    Those are two separate domains as far as cookies are concerned, but act as one on most web servers.

    To fix this, the admin needs to adjust the cookie domain settings in the AdminCP.

    So far, I've seen these issues:
    • Not working again - Use of different domain names in some area. Some links have www and some don't. This causes users to be logged off when they should be logged in. You will get a lot of complaints for this one. It happens on many BB systems. Are you using a redirect on www? Even though I see www in links, they are not going to those. This might be what is causing the login issues. See http://www.rockbandgame.com/vbforum/showpost.php?p=1448&postcount=7
    • After changing my profile settings for the timezone, it wants to go to an ip that starts with 172. It is not using the domain name.
    • Fixed - Announcements not at top in forum list (Not a bug, just symantecs)
    • Suggestion: Imported members have the "Instant Email Notification" turned on by default. This option might have been hidden in the other software so we could not change it and it was imported here. In time, your email server will have a lot of outgoing emails when the site gets busy. Perhaps turning this off and let the user decide?
    • Conversion to vB left   in some posts. Here's one of them: http://www.rockbandgame.com/vbforum/showpost.php?p=594&postcount=1 . This one has more markup language tags besides   : http://rockbandgame.com/vbforum/showthread.php?t=41 Also, see next note.
    • Viewing a single post makes it centered.
    • Some original BBcode tags are not being translated in vB. New bbCode needs to be added to vB to support old posts. See this post for the issue: http://www.rockbandgame.com/vbforum/showpost.php?p=1578&postcount=12
    • Topics/Boards not being marked as read due to below post: http://www.rockbandgame.com/vbforum/showpost.php?p=1438&postcount=4
    • Private Messages: "Total" value is incorrect. Need a new PM to see if "Unread" is correct. Maybe not tied into the phpfox PM system? If not, maybe this section should not be shown?
    • Signatures not showing in vB. The link to edit your sig in vB goes back to phpfox's profile page where the old sig is but that entry is not being shown here. Maybe purposely by your setting to not show sigs or a bug if sigs are allowed here.
    • Post count incorrect - Posts from old forum not counting in total posts by member.
    • Links in footer have issues
      [list]
    • TERMS & CONDITIONS - New popup window produces an Javascript type Alert window but displays after clicking OK.
    • PRIVACY POLICY - New popup window produces an Javascript type Alert window but displays after clicking OK.
    • HELP GUIDE - Javascript error. Does not work.
    • CONTACT US - Bad URL. Does not work.
    • INVITE - Bad URL. Does not work.
    • ABOUT US - Bad URL. Does not work.
    • PRESS - Javascript error. Does not work.
    [*]Fixed but see Update #3 @ http://www.rockbandgame.com/vbforum/showpost.php?p=1448&postcount=7
    - Unable to show as logged out in vB. See: http://www.rockbandgame.com/vbforum/showpost.php?p=1499&postcount=11
    [/list]

    I'll post more when I come across them.

    ETA:
    It's IP 172.{{ removed}}. You can see this when you go into your UserCP".
    Added "Instant Email Notification" default settings.
    Added Centered single post views
    Added Conversion missed non-breaking space code:  . Found other markup language tags.
    BBCode LINK not converted.
    Topics/Boards not marked as read after viewing them due to cookie subdomain issue and/or mixed use of www in domain name.
    Added PM totals not correct.
    Added signatures not showing in vB.
    Adding post count not including posts from old forum.
    Adding footer links have issues.
    Adding Unable to show as logged out in vB.
    Adding Original bbCode testing for failing bbCode in vB.
  • edited April 2007
    More on the subdomain www of rockbandgame in links:

    I use Firefox as my main browser. If I leave off the leading www for a site, it adds it for me.

    If I go to rockbandgame.com, it puts me at www.rockbandgame.com. I can force it by removing the www. Now if I click any of the links from the horizontal menu (Main/Browse/Blogs/etc), it redirects me to www.rockbandgame.com on all the phpfox links and the new Forum link.

    This is where a problem occurs.

    If I view the main forum index, the links on the right for the last topic look like they go to www.rockbandgame.com but they go to rockbandgame.com for me. The topic does come up but because my cookie is for www.rockbandgame.com (which phpfox assigned when I logged in), vB does not see me logged in.

    ADDING:
    Another area where the www is dropped is when a topic has a new reply and displays
    image.
    Example:
    The link properties show http://www.rockbandgame.com/vbforum/showthread.php?goto=newpost&t=92 but clicking the image brings me to http://rockbandgame.com/vbforum/showthread.php?goto=newpost&t=92 which again thinks I'm not logged in.

    ADDING #2: I might have found another area where it is messing up. It look's like it might be the redirect URL. I just edited this post and saw the redirect put me at rockbandgame.com instead of www.rockbandgame.com. I didn't notice this before since I was using the quick edit feature, which worked okay before. This time, I used the "Go Advanced", which is the same as clicking the Reply button. After I posted the edit, that is when it sent me somewhere else.

    I hope that explains it better.
  • edited April 2007
    Hate bumping my own replies but editing my reply above to add more things found probably does not mark this topic as having a new reply.
  • edited April 2007
    Don't worry, I am monitoring this closely and have stickied the topic. We are going to try to fix a good deal of this for tomorrow.
  • edited April 2007
    hmxsean;1446 said:
    Don't worry, I am monitoring this closely and have stickied the topic. We are going to try to fix a good deal of this for tomorrow.
    Thanks Sean. I just updated this reply with more info on the www subdomain and it being dropped somewhere in vB, leaving me logged out.

    UPDATE:
    It is definitely the Post Reply, not quick reply, which is dropping the www after posting. Based on what I have seen so far, it is probably the redirect link causing all these issues with dropping www for me. And with the cookies setting in vB storing separate ones for each domain, www and !www, this makes my browsing ... shall we say ... interesting.
    I'm sure changing the cookie setting in AdminCP to the following should make the logouts disappear at least:
    • Path to Save Cookies: / - No custom setting unless you want more than one vB on the domain.
    • Cookie Domain: .rockbandgame.com - This will make it store both www and !www cookies in the same cookie. Log out issues gone. Do not do this if you want more than one vB in the same domain though.
    UPDATE:
    It seems to be fixed now Sean. The cookie domain and path act like they are set to above now. I remain logged in in either www.rockbandgame.com or rockbandgame.com. I viewed the cookie here via Firefox to confirm this setting.

    UPDATE #2:
    Tested again after clearing cookies from this domain. Still an issue with phpfox now.
    phpfox seems to be using www.rockbandgame.com as it's cookie domain and two different paths for the cookie, / and /plugins/vbulletin/ but vBs is okay now.
    What happens now is if the user uses rockbandgame.com (without the www) in phpfox main page ( http://rockbandgame.com/index.php?do=/public/ ) and logs in via the form at the top, phpfox sets cookies as mentioned. Even though vB is fixed, with it changing the URL within it (another issue) by removing or adding the leading www, phpfox will not see the user as logged in should they go back to any phpfox area with the www added to it.

    Steps to reproduce:
    • clear all cookies from this domain.
    • go to http://rockbandgame.com/index.php?do=/public/
    • log in via the form at the top. (you will see the URL change to www leading it)
    • move around vB until the URL does not have the leading www (or remove it yourself but that defeats common user usage)
    • Now with www removed, go back to any phpfox page (your account, etc). It does not see you as logged in
    I do not have phpfox to check but maybe you can set the cookies settings there like you did vB?

    UPDATE #3: - 4/26/07
    This was fixed when the cookie domain was set to .rockbandgame.com but because phpfox and it's vB plugin are storing cookies at www.rockbandgame.com, this caused the system to not log out the user in vB when they logged out from the site.
    Now it seems the cookie domain was changed back to www.rockbandgame.com or even left blank (tested logging in without the www prefix subdomain and checked cookies) What happens now is the original problem. When a member logs in to www.rockbandgame.com , any time they are in the forum at a URL that does not have www.rockbandgame.com, vB will not see them as logged in.
  • TRY2KPUPTRY2KPUP Unsigned
    edited April 2007
    Im so confused... Are there two logins now? :confused:
  • edited April 2007
    TRY2KPUP;1454 said:
    Im so confused... Are there two logins now? :confused:
    TRY2KPUP,
    Just one. Using the login page from either the forum or the old way bridge them both together.
    There is a current issue though with this. If you login via the old way (top link) to www.rockbandgame.com , there is a mismatch in the cookie paths and domain name that causes some pages in the new vB forums to think you are not logged in (when the www is removed from the URL).

    Sean,
    The IP 172.nn.nn.nn {{removed and replaced real #s with n}} is in internal number I still come across. I tested this by forcing a logout and then used the vB login screen by forcing it to come up by going directly to a page where I needed to be logged in (my example, newreply.php like this URL : http://www.rockbandgame.com/vbforum/newreply.php?do=newreply&p=1454 ) Then at the vB login, I entered my information and submitted. It confirmed that I successfully logged in but the redirect page was trying to send me to IP 172.nn.nn.nn {{removed and replaced real #s with n}}

    Adding:
    I checked the html output for that IP and found it as part of the cron "image" which triggers cron jobs, if needed.
    I then checked my local copy of vB and the source is using the value stored in one of the sql records. What I also found interesting is the other areas that keep trying to use this 172 IP is also using this value.

    This setting can be checked/changed in the AdminCP under ...
    • vBulletin Options
      [list]
    • vBulletin Options[list]
    • Site Name / URL / Contact Details[list]
    • Forum URL
    [/list][/list][/list]

    Maybe the current value stored there is set to IP 172 .... ?
  • edited April 2007
    I wonder how long it will be before Sean bans me here for posting this stuff? ;)
  • edited April 2007
    I can not get vB to show that I am logged out.

    Steps to reproduce for me:
    • Clear all cookies from this domain
    • Go to site's main page www.rockbandgame.com/index.php
    • Fill in Login information at top of screen and select the "Login" button.
      Navigate around including vB to verify login worked.
    • Select either the LogOut link at very top or the Logout link in vB near your username.
      At this point, you will be redirected back to the main page.
    • Select "Forum" from nav links under top banner.
    • Note logged in state.
    UPDATE:
    Fixed but see Update #3 at http://www.rockbandgame.com/vbforum/showpost.php?p=1448&postcount=7
  • edited May 2007
    Below is a list of bbcode that the old system used and the results of them being used/shown in vB. This will help determine which new bbCode tags need to be created, Custom bbCode, in vB to support pre-conversion posts.

    HTML tags will be covered in a separate reply.

    Failed conversion is noted to the right of each bbcode.
    Valid bbCode posted below has a space after the leading [ character to prevent bbCode from triggering.

    From the help guide of original forum.
    *******************************

    HTML Tags

    [user][/user] - Does not convert
    If you want to make a link to another member here at rockbandgame.com use those tags.
    Example: [user]Nickname[/user] will make a link to User's profile.

    [profile][/profile] - Does not convert
    If you want to make a photo link to another member here at rockbandgame.com this site use those tags.
    Example: [profile]Nickname[/profile] will show a photo of User with a link to User's profile.

    [link=""]Description[/link] - Does not convert
    If you want to make a link to another site, you can use the [link] tag.
    For example: [link="http://www.yahoo.com"]Yahoo[/link]. Notice that you have to have the "http://" before the adress to link to a site outside of rockbandgame.com

    [br] - Does not convert
    This is a very useful tag. It will make an empty row in your text, use it to make your text look better and easier to read.

    [hr] - Does not convert
    This will simply make a horizontal line, which can also make your text and place look better.

    [ img][ /img]
    If you want to add an image.
    For example:[ img]http://www.rockbandgame.com/vbforum/images/buttons/reply.gif[ /img] displays
    image
    That will add the image to wherever you post. All you need to make sure is that you have the right URL and dont forget the http://

    [ color=""][ /color]
    If you want to change the color of your text.
    For example:Will make this text blue
    You can also use the exact rgb values between 0-f
    For example:Will make this text red
    Note: If you want to use the exact rgb color you cannot leave out the "#" sign before the rgb color.

    [ quote=""][ /quote]
    If you want to quote something someone has said. This is already set in the forums by clicking on QUOTE, but can be placed anywhere.
    For example:
    username" said:
    Something to be said here
    [ quote][ /quote]
    If you want to quote something someone has said.
    For example:
    Something to be said here
    [em][/em] - Does not convert
    If you want to emphasis part of a text.
    For example: I want to [em]emphasis[/em] this word.
    Will be displayed like: I want to emphasis this word.

    [strong][/strong] - Does not convert
    If you want to have part of your text to be strong.
    For example: I want [strong]this[/strong] today.
    Will be displayed like: I want this today.

    [ email][ /email]
    If you want a email to be clickable
    For example: Send to my email here: [ email]something@somemail.com[ /email].
    Will be displayed like: Send to my email here: [email]something@somemail.com[/email].

    [ul][/ul] and [li] - Does not convert
    This is used if you want to have a list.
    For example:
    [ul]
    [li]Test 1[/li]
    [li]Test 2[/li]
    [li]Test 1[/li]
    [/ul]
    Will be displayed like:

    * Test 1
    * Test 2
    * Test 1


    [ol][/ol] and [li] - Does not convert
    This is used if you want to have a ordered list with numbers.
    For example:
    [ol]
    [li]Test 1[/li]
    [li]Test 2[/li]
    [li]Test 1[/li]
    [/ol]
    Will be displayed like:

    1. Test 1
    2. Test 2
    3. Test 1


    [ size=""][ /size]
    If you want to change the size of your text.
    For example:Will make this text bigger
    Note that you can change the size from 1-7.

    [ center][ /center]
    If you want to center your text or images on the page you can use this tag.
    Example: [center]centered[/center]

    [ b][ /b]
    Example: Will make this text bold

    [ i][ /i]
    Example: Will make this text italic

    [ u][ /u]
    Example: Will make this text underlined

    [align=""][/align] - Does not convert
    If you want to align your text. The input options are: left,center and right
    For example:
    [align="right"]
    Will align this text to the right
    [/align]

    [table=""][/table] and [td] - Does not convert
    This is used if you want to create a table and place things in a certain way.
    For example:
    [table=75]
    [td]Test 1[/td]
    [td]Test 2[/td]
    [td]Test 1[/td]
    [/table]
    Will be displayed like:
    Test 1 Test 2 Test 1

    Note: ( 75 ) is the width of the table in percent. So you can have a table from 0-100.
  • edited May 2007
    UPDATE: 5/18/07 - This issue looks to be fixed now with the exception of that one &nbs p; code I found somewhere in the forum.


    The conversion of old forum posts to vB left many posts with html tags that were not converted to the new bbCode of vB.

    Below is a list of what I found so far:

    ------------------------

     
    &nbs p;

    ------------------------








    ------------------------

    Text Here


    Text in here


    ------------------------
    image
    image
    image

    ------------------------




    Left

    center

    Right

    Full

    ------------------------

    Color here

    ------------------------
    Font size here

    (

    Comic Sans font

    ------------------------
    Strong text here

    ------------------------
    Bold text here

    ------------------------
    Emphasized

    ------------------------
    Italic

    ------------------------

    Youtube vid


    ------------------------


    This is spanning something

    In the enclosed attachment, you will find a program that I wrote today to convert these.
    Maybe your IT staff could use it. I would hate for visitors to your company's forum stumble upon the old posts here and see it in disarray.

    phpfoxfix.php is used for vB's that tried to convert and changed all the html tags to something else;
    for example: < became < > became >

    phpfoxfix2.php is used for vB's that did not convert the post and html tags as is;
    for example: < is still < and > is still >

    ******************
    Example for phpfoxfix.php:

    Original html tag:

    text

    Looks for converted html tag: <p>text</p>


    Example for phpfoxfix2.php:

    Original html tag:

    text

    Looks for html tag:

    text


    Notes:
    Old LIST tags deleted? No trace of them.
    http://rockbandgame.com/vbforum/showpost.php?p=1260&postcount=1
    http://rockbandgame.com/vbforum/showpost.php?p=1246&postcount=1

    UPDATE to include new fix
    UPDATE: 5/18/07 All fixed except that one &nbs p; I found posted somewhere.
  • edited May 2007
    Email notification of new Private Message has stopped working.

    This did work before the switchover to vB however it might not be directly linked to vB. My PM options in vB have PM email notification turned on. Maybe the other system is at fault or had that feature turned off.
  • edited May 2007
    Email notifications of Subscribed Topics is not sending emails.

    Reproduce by:
    Subscribe to a topic via the Thread Tools menu while viewing a topic.
    Select "Instant notification by email", leave folder to defaulted one.
    Note when a new reply to made to that topic, no email is sent.
    I have not tried daily or weekly updates.

    I confirmed that my email system is working on my domain by doing the same via another website.
  • TRY2KPUPTRY2KPUP Unsigned
    edited May 2007
    I still cant login to my damn profile.... Im logged into the forums, but not the profile section of the site...
  • edited May 2007
    TRY2KPUP;1812 said:
    I still cant login to my damn profile.... Im logged into the forums, but not the profile section of the site...
    This has happened to me before cookies were changed here. I had to clear all cookies for this domain for it to work correctly. Until you do that, it will not work correctly.
  • benjaminbenjamin Opening Act
    edited May 2007
    So Huskie, I assume you have your own Vbulletin forum eh? Or are you just a general computer guy.
  • edited May 2007
    benjamin;1847 said:
    So Huskie, I assume you have your own Vbulletin forum eh? Or are you just a general computer guy.
    Both but the vB software is only used locally for supporting and creating custom mods for a few sites I've worked for which own the licenses.
  • TRY2KPUPTRY2KPUP Unsigned
    edited May 2007
    Huskie;1844 said:
    This has happened to me before cookies were changed here. I had to clear all cookies for this domain for it to work correctly. Until you do that, it will not work correctly.
    I deleted all cookes, just before I made that post.
  • edited May 2007
    HTML tags in preconversion forum posts have been cleaned for the most part.
    http://www.rockbandgame.com/vbforum/showpost.php?p=1581&postcount=13 has a sampling of the bad conversion which looks cleaned now, except that one non-breaking space tag that is badly malformed. I can't even remember the post where I found that one.

    Just an FYI.
    The page centering issue of viewing a single post, by clicking that link, is still open.

    Edit to add:Maybe the posts were selectively cleaned because I found another one with two html codes in it.
    http://www.rockbandgame.com/vbforum/showpost.php?p=439&postcount=1
  • TRY2KPUPTRY2KPUP Unsigned
    edited May 2007
    Woohoo! Its Fixed! :d
  • Rock_StarmanRock_Starman Headliner
    edited June 2007
    I can't change anything on my user CP. I click on it and it tells me to log-in again,I do and then it says log-in successful but goes back to the log-in screen again. :confused:
  • edited June 2007
    Server response is painfully too slow based on the current users on it
    Currently Active Users: 30 (8 members and 22 guests)
  • edited June 2007
    Oh yeah, we know (it is painfully slow for me as well.) Apparently we are having an issue where our intertubes are clogged, so it isn't the servers this time. Soon, though, we will have a whole new set of servers set to full awesomosity at a remote location with uncloggable intertubes that I am told is "outside Boston's blast radius." That means if the world goes into full nuclear warfare our website will still be going strong even if we are painfully mutated and incapable of finishing the game what with our second heads to deal with and all that.
  • edited June 2007
    Dude..... I have so been wanting a second head. Bring on the radiation!!!
  • sonic064sonic064 Unsigned
    edited June 2007
    Any 360 user of q has the GH2 is careful with the following error of the game, this are the steps to do it:

    1. - A data of the game and a band.
    2. - Later it creates another band, but this errase it.
    3. - The go to the menu of the 360.
    4.- Put again the game, but when you load your data the screen freeze and you can't play again.
  • edited June 2007
    sonic064;6800 said:
    Any 360 user of q has the GH2 is careful with the following error of the game, this are the steps to do it:

    1. - A data of the game and a band.
    2. - Later it creates another band, but this errase it.
    3. - The go to the menu of the 360.
    4.- Put again the game, but when you load your data the screen freeze and you can't play again.
    This is actually for the reporting of bugs on this website. If you are having problems with GH2 you should probably report them here-

    http://www.redoctane.us/support-center/

    as they handle Customer Support for the Guitar Hero series.
  • newwaytodienewwaytodie Road Warrior
    edited June 2007
    You know what they say two heads are better than one. *rimshot*
  • edited July 2007
    newwaytodie;7278 said:
    You know what they say two heads are better than one. *rimshot*
    That is true ... and this server is better than the last one.

    Server speed issue seems like it's behind you now Sean. I'd cross it off the list myself but it got lost somewhere back there on page 1.

    Kudos to this beast on steroids.
    The real test will be when HMX releases new information. :D

    PS: It might be wise to remove any sharp objects from Mattmoss' work area.
  • edited September 2007
    Suggestion / Opinion:

    Disable HTML code in posts.

    They will only lead to people abusing it.
    We've seen Whamulance use IFRAMEs here which change the browser's size, position and inability to close easily by redirecting the browser offsite and loading one of his own pages. That member littered the General forum with these types of posts.
    The outcome of his 'test' page might be viewed as just a joke but he could have easily coded his page to harm your computer. He still can, even if he gets banned. As long as his posts remain, people here are vulnerable. He can also redirect the viewer to any URL of his choice - Pornography, etc.

    We all know Internet Explorer is notorious for allowing harmful code to be installed on the viewer's computer just by visiting a site/page that has been purposely designed to caused this harm. I fight these types of virii/worms/trojans weekly on infected work computers and some of these can be a real pain to remove. Your average Joe is not going to be able to remove some of the latest ones that have been released.

    So I beg you, for the sake of the community here, disable HTML code for posts. There is no reason for anyone here to use it.

    Now a question.
    Does the "Report a Post" feature work here? I have not been getting emails myself from other parts of the site and if that feature uses emails to alert you, you might not be getting them.
  • edited September 2007
    Wow Huskie, that's some crazy detective work. It definately seems like you have a web developer type background and/or very strong experience with this message board system.

    I was all set to issue a bug report, but compared to yours it would have sounded like

    "I push the buttons and the page doesn't work!" ;)
This discussion has been closed.