Midi adapter Wii issue

oliverzpoliverzp Unsigned
My Midi adapter for wii is having issues. it only wants to work sometimes.

It has trouble powering on and getting recognized as a game controller.

Sometimes no matter how many times i press the power on button it wont turn on. however at other times it has gotten to work.

After trying last night for a long time, it had the problem again. at first i thought it was completely defunct but i noticed the midi indicator does light up when i hit keys on my keyboard. the only problem is the controller wont turn on and get recognized by the game when i press the rock band button.

Somtimes it DOES work however.

I cant notice a pattern around when it will turn on and when it wont, it seems a bit arbitrary to me.

My question is, do you think this is an issue with the rock band software? i have heard the wii version is super glitchy and i have experienced a few of them myself. is this some kind of usb recognition error by the rock band wii software? or is this an issue with the adapter itself and would a replacement fix the issue?

Perhaps i just got unlucky and got a faulty adapter. on amazon.com i haven't read anywhere about this issue in the reviews and it has 4.5 stars so it doesnt seem to be that common a problem.

I did read somewhere else someone had a similar issue and their solution was to simply reset the game and reconnect the midi controller. This however didnt work when i tried.

Any help would be appreciated!

Thanks

Comments

  • Bront20Bront20 The Writing's on the Wall
    edited June 2013
    1) Use enter, that text block is hard to read.

    2) Make sure you have no more than 4 controllers hooked up at any time. Turn off all the Wiimotes you don't need as well. My guess is that it's an issue of too many active controllers so you get kicked off past controler 4.
  • MarkerooMarkeroo Unsigned
    edited June 2013
    Bront20;5021509 said:
    Make sure you have no more than 4 controllers hooked up at any time.

    +1. Try starting up RB with just one WiiMote turned on, then once the game has started up (that is, when you get past the Break On Through intro) press the blue Rock Band button on the Midi Pro adapter.

    Sometimes, even when you have fewer than four connections, RB on Wii won't let you in because it expects your controller to go in a particular slot (among the 4 available) and that slot is already filled. It's annoying, but it *SHOULDN'T* be a hardware issue if your MPA works "sometimes."
  • oliverzpoliverzp Unsigned
    edited June 2013
    i tried starting with no other controllers plugged in. i even tried turning the wiimote off and it still wouldnt connect.

    it came on once again today but after restarting the game it didnt work again, so it still doesnt work all the time
  • ShadowzIShadowzI Unsigned
    edited June 2013
    I can attest to the wii having usb issues.
    The wii actually has 3 problems with the controller.
    1) Problem recognizing over 3 controllers
    2) Lag when the wii is left on for too long
    3) Usb recognition

    Fortunately you seem to be only experiencing the third one and I usually solve this easily by first turning on the wii with the adapted connected to the instrument and the console (switch to K for Keyboard G for Guitar and D for Drums) while making sure my instrument has power to send to the midi cable.
    Load up rockband and go all the way to the start screen. Finally when you can press the home button open it and press the reset button. If everything is going according to plan your adapter should start lighting up like a Christmas tree while your on the black screen of reset. After that wait to you hit the main screen again and hit the (RB) button.

    I'm not sure how this process works without an instrument connected so I'll do a standalone test on Friday and tell you later.

    In the mean time
    If this does not work you may have other controllers interfering with the port receiver or your midi cable or midi jack or usb cable or usb slot (try using another slot) is shot.
    If anything I would try getting another midi reviver, they are 20$ and are discounted at GameShark (with the promo code Rock25)
  • oliverzpoliverzp Unsigned
    edited June 2013
    i tried resetting at the start screen but to no avail. i have tried connecting the midi adapter to every usb port on the 4-port HUB and the two on the wii itself while no other controllers are connected and it still doesnt work
  • ShadowzIShadowzI Unsigned
    edited June 2013
    Then more or less likely your midi pro adapter is shot D=.
    Your other controllers work right?

    Fortunately a new one is 15$ at the moment.
  • Bront20Bront20 The Writing's on the Wall
    edited June 2013
    Yeah, even if it starts working again, having a backup isn't a bad idea at that price.
  • oliverzpoliverzp Unsigned
    edited June 2013
    I'll have to get a new one then, thanks for the tips and info
Sign In or Register to comment.